attempting to boot from SD card

Asked by Jon Doher

     I am trying to install linux mint 9 from a 8 gig usb flash drive onto a microSD card (8 gigs as well) that will reside on a fit-pc2 that (if this resolves itself) will function as a router.
     I booted into live mode and ran the gui installer (ubiquity). I created one partition on the microSD card (ext3) on which I installed linux mint 9. I then powered off the machine and removed the usb flash stick. Once that completed I turned on the machine with the microSD card being the only source of bootable memory.
     After the boot sequence the screen turned dark for about 5 mins. After that an error message made itself known to me "Alert! /dev/disk/by-uuid/ab15b395-8a89-4cdd-92fc-573f79a52f07 does not exist" (without the quotes).
     I consulted google and the manufactures forums. They both advised me to mount the drive using the command "sudo e2fsck -fp /dev/sd##" (again without the quotes). I made the command relevant to my machine and ran it. This is what greeted me " e2fsck: Bad magic number in super-block while trying to open /dev/mmcblk0". I then tried looking up /dev/mmcblk0 in fstab, where it did not exist. dmesg however, tells me it's there (this is the only clue known to me that the machine recognizes it). I do not know what to do at this point

Question information

English Edit question
Ubuntu grub2 Edit question
No assignee Edit question
Solved by:
Jon Doher
Last query:
Last reply:
Revision history for this message
marcus aurelius (adbiz) said :

This site is for Ubuntu. Mint has its own help forum. Just google it.

Revision history for this message
Ubfan (ubfan1) said :

You should be checking the partition, not the device -- use mmcblk0p1 instead of mmcblk0.

Revision history for this message
Jon Doher (18deltamedic) said :

Mint is based off of Ubuntu no? and mmcblk0p1 gives me the same answer.

Revision history for this message
Ubfan (ubfan1) said :

Try reinstalling, making sure that you install to the mmcblk0p1 and not to mmcblk0. Check out the link for more tips.

Revision history for this message
Jon Doher (18deltamedic) said :

Followed the link and repartitioned the microSD to ext2 and installed using usb-creator-gtk. It actually booted this time (huzzah!) but then I recieved this error "(initramfs) Unable to find a medium containing a live file system" (without the quotes once again). This error gives me a psuedo-bash with limited commands.

This was of no help

Seems to have devolved into this

but with one caveat: None of the proposed solutions have worked, searching across different forums.

Revision history for this message
Ubfan (ubfan1) said :

Try your card in a usb reader, that may work. I don't have a machine which boots off SD so I cannot offer any more suggestions. You could try to run the live media, and check the sd card for errors:
sudo e2fsck /dev/mmcblk0p1

Revision history for this message
delance (olivier-delance) said :

you should reinstall Grub2. It's a classical issue.

Revision history for this message
Jon Doher (18deltamedic) said :

DIdnt help, and Im running off a usb now instead of the SD card, seems to work so far. Thank you for your help though.