flash plug-in won't install/reinstall/fix

Asked by natasha rose

One day my flash plug-in just stopped working, and I cannot recall if it was after a specific update. I've tried reinstalling the package.

I keep getting this: LANG=C;sudo apt-get update && sudo apt-get dist-upgrade

I have tried using Synaptic, using terminal
including following this: https://help.ubuntu.com/community/PackageManagerTroubleshootingProcedure

This is what I get through both terminal and synaptic:

Package is in a very bad inconsistent state - you should
 reinstall it before attempting a removal.
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Nothing works.

Any ideas?

Question information

English Edit question
Ubuntu flashplugin-nonfree Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Mark Rijckenberg (markrijckenberg) said :

Please try the solution from forumuser kansasnoob at this location:


I believe that your PC is experiencing this bug:


Revision history for this message
Best actionparsnip (andrew-woodhead666) said :

sudo mv /var/lib/dpkg/info/flashplugin-nonfree.prerm ~; sudo dpkg --remove --force-remove-reinstreq flashplugin-nonfree; sudo dpkg --purge --force-remove-reinstreq flashplugin-nonfree; sudo apt-get -f install; sudo apt-get clean; sudo apt-get update; sudo apt-get upgrade

Should be ok. If so, you can run:

sudo rm ~/flashplugin-nonfree.prerm

to clean up

Revision history for this message
natasha rose (natashabarcena) said :

Thanks actionparsnip, that solved my question.

Revision history for this message
actionparsnip (andrew-woodhead666) said :

This is one of the HUGE weaknesses in package based systems. There are guides all over the web for this.