Print doesn't work

Asked by Frank Gilmurray

I have a WorkForce Pro WF-3820 (Epson) on my wireless network. I can print from every other device (MacBook, Window box, and Samsung tablet) but not from my two Ubuntu systems running 20.04 and 22.04. It used to work about 2/3 weeks ago but then nothing. I have jobs sitting in the print queue for a couple of days but still nothing,

I noticed a phantom driverless printer was somehow added (not by me). Its name is <email address hidden>. If I remove it a few seconds later it just comes back. When I built these systems, the printer was automatically added and it worked just fine on both systems.

I'm at loss to explain and fix this problem.

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :

Did you install any driver software?

Revision history for this message
Frank Gilmurray (frankgil) said :

I haven't added any drivers in either Ubuntu. I choose this printer because Ubuntu could automatically install it. Indeed it worked perfectly until a few weeks ago. I check for and install the updates daily.

Revision history for this message
actionparsnip (andrew-woodhead666) said :

Epson have drivers available on their site. May help out

Can you help with this problem?

Provide an answer of your own, or ask Frank Gilmurray for more information if necessary.

To post a message you must log in.