Asked by Timofey Kargin

Sometimes (once in a few weeks) Chromium doesn't open pages and shows error "Oh, snap SIGTRAP".
If it happens, I can't use it for about 30 minutes. Incognito mode doesn't help, same as cache cleaning.

My system:
OS: Ubuntu 20.04 focal
Kernel: x86_64 Linux 5.4.0-65-generic
DE: KDE 5.68.0 / Plasma 5.18.5

Browser info:
me@mypc:~$ apt-cache policy chromium-browser
  Installed: 1:85.0.4183.83-0ubuntu0.20.04.2
  Candidate: 1:85.0.4183.83-0ubuntu0.20.04.2
  Version table:
 *** 1:85.0.4183.83-0ubuntu0.20.04.2 500
        500 focal-updates/universe amd64 Packages
        100 /var/lib/dpkg/status
     80.0.3987.163-0ubuntu1 500
        500 focal/universe amd64 Packages

I am not sure how to find logs. But.
me@mypc:~$/home/me/snap/chromium/common/chromium/chrome_debug.log | grep " sig"
In this output I didn't find anything suspicious

And now I can't repeat error, so I can't use gdb to have a log.

Any ideas? I found a lot of same questions on the internet including StackOverflow, but didn't succed.

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Manfred Hampl
Last query:
Last reply:
Revision history for this message
Manfred Hampl (m-hampl) said :

If you are using the snap version, then the output of apt commands does not tell anything useful.

The more relevant command in that case is
snap info chromium-browser

Revision history for this message
Timofey Kargin (kargintima) said :

As far as I remember, I used "sudo apt install chromium-browser" to install it.

And snap response like this:
me@mypc:~$ snap info chromium-browser
error: no snap found for "chromium-browser"

I could delete chromium and install it with snap. Should I?
But I am not sure if it will help. If I remember it correctly, installation with apt calls for snap on some stage of installation.

Revision history for this message
Manfred Hampl (m-hampl) said :

Sorry, my fault.

The (obsolete) Ubuntu .deb package was named chromium-browser, but the snap package is named chromium.

snap info chromium

Revision history for this message
Timofey Kargin (kargintima) said :

Yes, you are right.
timofei@timofei:~$ snap info chromium
name: chromium
summary: Chromium web browser, open-source version of Chrome
publisher: Canonical✓
license: unset
description: |
  An open-source browser project that aims to build a safer, faster, and more stable way for all
  Internet users to experience the web.
  - chromium.chromedriver
  - chromium
snap-id: XKEcBqPM06H1Z7zGOdG5fbICuf8NWK5R
tracking: latest/stable
refresh-date: 3 days ago, at 13:05 MSK
  latest/stable: 88.0.4324.182 2021-02-18 (1497) 143MB -
  latest/candidate: 88.0.4324.182 2021-02-18 (1497) 143MB -
  latest/beta: 89.0.4389.58 2021-02-20 (1500) 145MB -
  latest/edge: 90.0.4421.5 2021-02-19 (1498) 147MB -
installed: 88.0.4324.182 (1497) 143MB -

Revision history for this message
Best Manfred Hampl (m-hampl) said :

Maybe what you see is Bug #1914918

Revision history for this message
Timofey Kargin (kargintima) said :

Thanks Manfred Hampl, that solved my question.

Revision history for this message
Timofey Kargin (kargintima) said :

 I think so
Anyway, I will wait for an update solving this bug