Wireless Connection on Macbook running Intrepid

Asked by Fara

I've set up my Macbook (version 2,1) to dual-boot with OS X and Intrepid Ubuntu. When I got it running, I found that I had extremely inconsistent wireless support that would typically die within five minutes of selecting a hub. I followed the advice on the https://help.ubuntu.com/community/MacBook2-1/Hardy page, compiling the ath9k and installing it. However, when I rebooted, I found that I no longer could no longer utilize wireless at all! I can't select any option in the Network menu except for wired access. How would I get my wireless to work again?

(I tried following the instructions for Intrepid on the wiki page, but Hardware Drivers doesn't recognize any restricted drivers.)

Computer: Macbook 2,1
OS: Intrepid Ibex

Thank you for your help!

Question information

English Edit question
Mactel Support Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Ernest Yang (ernest-atheros) said :

Some questions:
1. Can you find/configure the wireless interface by "iwconfig" ?
2. ath9k is 11n driver, does your access point correctly configured?

Revision history for this message
Fara (faratay) said :

1: iwconfig shows that I have three connections: lo, eth0, and pan0. All three of them say they have no wireless extensions, and running any iwconfig commands to configure the three bring up the same error: "SET failed on device [lo, eth0, or pan0]; Operation not permitted."

2. I'm on a university campus, so I can't configure the access points themselves. But I do know that the hub nearest me is a Cisco 1100. The wireless adapter in my computer is an Atheros Communications Inc. AR5008 Wireless Network Adapter (rev 01).

Revision history for this message
Ernest Yang (ernest-atheros) said :

1. lo, eth0, pan0 are not wireless LAN interface. If your wireless card is bringup successfully, you should see "wlan0" or "eth<number>" and have wireless extension.
2. You have to bringup wireless driver first, check if ath9k is inserted by "lsmod | grep ath9k", if it is not loaded, try to load it from /lib/modules/<kernel version>/kernel/driver/net/wireless/ath9k/ath9k.ko

Revision history for this message
Fara (faratay) said :

Could you explain the commands needed to load the .ko file? I can't figure out the right commands...

Revision history for this message
Ernest Yang (ernest-atheros) said :

1. cd /lib/modules/<kernel version>/kernel/driver/net/wireless/ath9k/
2. insmod ./ath9k.ko
3. use "ifconfig -a" and "iwconfig" to check if wireless interface brings up.

Revision history for this message
Fara (faratay) said :

Thanks for the commands. When I run insmod, I get this error: "Unknown symbol in module". How can I fix this?

Revision history for this message
Ernest Yang (ernest-atheros) said :

1. There are dependencies on other modules, use "dmesg" to see the message, post it here.
2. you can try "modprobe ath9k" it should automatically load all dependent modules.

Revision history for this message
Fara (faratay) said :

The error messages:

Unknown symbol ieee80211_start_tx_ba_cb_irqsafe
Unknown symbol ieee80211_free_hw
Unknown symbol ieee80211_alloc_hw
Unknown symbol ieee80211_start_tx_ba_session_
Unknown symbol ieee80211_register_hw
Unknown symbol ieee80211_rate_control_unregister
Unknown symbol ieee80211_get_hdrlen_from_skb
Unknown symbol ieee80211_wake_queue
Unknown symbol ieee80211_rate_control_register
Unknown symbol sta_info_get
Unknown symbol __ieee80211_rx
Unknown symbol ieee80211_stop_queue
Unknown symbol ieee80211_stop_queues
Unknown symbol ieee80211_unregister_hw
Unknown symbol ieee80211_beacon_get

The same errors appear a few times in the message. (I get the same error with modprobe.) I'm guessing the problem is ieee80211. I looked at Ubuntu Package Search for any packages with ieee80211, but they don't have any sources for Intrepid.

Revision history for this message
Fara (faratay) said :

Got it! I found a solution here: http://guide.ubuntuforums.org/showthread.php?t=882785

To any future person with this problem, don't bother with net-tools. I did that one alone, and it didn't bring up wireless. I'm not sure which out of linux-generic, linux-headers, or linux-image did the trick, but at least it works.

Thank you for your help, Ernest!