Unable to login using the new Firefox version 94.0

Asked by Bernard Stafford

I am unable to login to any Ubuntu server using my Ubuntu One.
My system just upgraded my Firefox to version 94.0.
The servers are not recognizing the new web browser.
I get this reply when I login:
"Bad Request"
"Bad bot, go away ! Request aborted."
I had to start my Ubuntu 20.04 in virtual box with Firefox version 93.0 to login to this site.
Thank You in advance.

Question information

English Edit question
Canonical SSO provider Edit question
No assignee Edit question
Solved by:
Daniel Manrique
Last query:
Last reply:
Revision history for this message
Cristian Gonzalez (cristiangsp) said :

Hi Bernard,

It's possible that you are using a password manager to auto fill your credentials? We have received some reports in which the auto completion was the issue. Could you try without it so we can go to the root cause?


Revision history for this message
Bernard Stafford (bernard010) said (last edit ):

I manually logged in:
[same as before, with the same reply].
Pop-up blocker is off.
Browser privacy set to Standard: Web pages load normally.
Currently logged in with Firefox 93 on Ubuntu-Virtual Box
New Security fixes in Firefox 94

Revision history for this message
Bernard Stafford (bernard010) said :

What is the status of my login problem with the new Firefox 94 ?
All of my contacts for translations and answering questions are on
my host computer.
Eventually Ubuntu will update to the new Firefox 94. Then how do we login ?

Revision history for this message
Bernard Stafford (bernard010) said :

Firefox just updated to version 94.0.1 the login problem still is the same.
I even deactivated my GPG Key to see if it had anything to do with the login
problem. No change at all still unable to login.
Curious to know why the launchpad Server thinks I am a BOT trying to login.

Revision history for this message
Bernard Stafford (bernard010) said :

I am able to login to https://discourse.ubuntu.com
and login to https://iso.qa.ubuntu.com/qatracker.
I am not able to login to https://launchpad.net
or https://answers.launchpad.net/ubuntu
or https://launchpad.net/~bernard010
Which is my home page for launchpad.

Revision history for this message
Best Daniel Manrique (roadmr) said :

Hi there,

can you try logging in directly to https://login.ubuntu.com?

If you still get the "bad bot" message, it means that something (usually a password manager, either the browser's built-in one or a third-party one) is filling out a hidden field we use to detect bots.

What I would recommend in this case, to "fix" the auto-fill or password manager's idea of whether that field needs to be filled out (it does not):

- write down your login/email and password.
- Delete the login.ubuntu.com and login.launchpad.net records from your password manager and auto-fill databases (this is dependent on which solution you're using, I suggest googling for specifics)
- Try logging into https://login.ubuntu.com again, with the password you wrote down.
- When the password manager prompts you to save the site, please do so, it should now have the correct information.

Revision history for this message
Bernard Stafford (bernard010) said :

[SOLVED] Must of been the new Firefox update.

Revision history for this message
Bernard Stafford (bernard010) said :

Thanks Daniel Manrique, that solved my question.